吾爱汇编

 找回密码
 立即注册

QQ登录

绑定QQ避免忘记帐号

查看: 1976|回复: 14

dll补丁问题

[复制链接]
3044598236 发表于 2021-8-25 15:24 | 显示全部楼层 |阅读模式

本站严厉禁止求脱求破行为(包含无自我分析直接求思路),如发现此类求助主题请点击“举报”,让我们共同维护优质的学习环境!


50HB
本帖最后由 3044598236 于 2021-8-25 15:40 编辑

一个某盾逆向后会在c盘生成一个dll, dll有二次验证, 加了se壳,dll貌似会检测游戏是否运行,游戏运行后就会加载这个dll,我想在游戏加载dll前拦截下来,然后修改我在论坛找到一份源码
K~SWHY3J6D7$(AABZG3FZSC.png
通过hookLoadLibraryA来劫持,我把生成的劫持补丁放到游戏运行目录,补丁地址我反复测试是正确的
貌似是补丁劫持不了游戏,我附加游戏发现补丁和dll都是在游戏调用LoadLibraryA时被加载的,补丁也没有打上
请教各位大佬能否给个打这种补丁的教程,hb不够可以加上上个帖子,请各位大佬看看附上源码和dll,https://wws.lanzoui.com/ivYDWt5cybg,源码密码123456



最佳答案

吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
Eric 发表于 2021-8-25 15:24 | 显示全部楼层

最佳答案本应属于楼主私有,因此限制查看

您还有0次查看次数,点此查看答案

点此购买查看次数
也可以兑换VIP特权或加入解密专家,每日可免费查看5次最佳答案!

吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
涛涛 发表于 2021-8-25 16:39 | 显示全部楼层

HOOK 载入窗口函数,启动线程 检测是否加载了这个DLL,剩余的就不用说了!
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
 楼主| 3044598236 发表于 2021-8-25 17:19 | 显示全部楼层

涛涛 发表于 2021-8-25 16:39
HOOK 载入窗口函数,启动线程 检测是否加载了这个DLL,剩余的就不用说了!

CreateWindowExA大佬,是这个函数吗
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
 楼主| 3044598236 发表于 2021-8-25 17:51 | 显示全部楼层

3044598236 发表于 2021-8-25 17:19
CreateWindowExA大佬,是这个函数吗

hook这个函数的时候dll还没有解码
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
Eric 发表于 2021-8-25 19:06 | 显示全部楼层
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
 楼主| 3044598236 发表于 2021-8-25 19:59 | 显示全部楼层

Icpower 发表于 2021-8-25 19:06
枚举模块先,枚举到了再进行

大佬能否帮忙改写一下,小弟愚钝,不怎么会写
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
Eric 发表于 2021-8-25 22:38 | 显示全部楼层

[ecode=1=1].版本 2

.局部变量 result, 精易_模块信息
.局部变量 n, 整数型

进程_ID取模块 (进程_名取ID (“xxx.exe”, ), result)
.计次循环首 (取数组成员数 (result), n)
    .如果真 (result [n] = “xxx.dll”)
        ' 这里写补丁
        跳出循环 ()
    .如果真结束

.计次循环尾 ()
[/ecode]
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
 楼主| 3044598236 发表于 2021-8-25 23:41 | 显示全部楼层

本帖最后由 3044598236 于 2021-8-25 23:44 编辑


                               
登录/注册后可看大图
大佬,不知道是不是劫持补丁的问题,这样写补丁也没打上,信息框也没弹出来,我把进程id换成pid也不行,
是哪里写错了吗,这样写在hook会报错,我就没hook了
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
 楼主| 3044598236 发表于 2021-8-26 08:35 | 显示全部楼层

Icpower 发表于 2021-8-25 22:38
[ecode=1=1].版本 2

.局部变量 result, 精易_模块信息


Z%H$VP7F~1@[HA%5R7_ZQE1.png

大佬,不知道是不是劫持补丁的问题,这样写补丁也没打上,信息框一个都没弹出来,
是哪里写错了吗,这样写再hook会报错,我就没hook
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

警告:本站严惩灌水回复,尊重自己从尊重他人开始!

1层
2层
3层
4层
5层
6层
7层
8层
9层
10层

免责声明

吾爱汇编(www.52hb.com)所讨论的技术及相关工具仅限用于研究学习,皆在提高软件产品的安全性,严禁用于不良动机。任何个人、团体、组织不得将其用于非法目的,否则,一切后果自行承担。吾爱汇编不承担任何因为技术滥用所产生的连带责任。吾爱汇编内容源于网络,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑中彻底删除。如有侵权请邮件或微信与我们联系处理。

站长邮箱:SharkHeng@sina.com
站长QQ:1140549900


QQ|RSS|手机版|小黑屋|帮助|吾爱汇编 ( 京公网安备11011502005403号 , 京ICP备20003498号-6 )|网站地图

Powered by Discuz!

吾爱汇编 www.52hb.com

快速回复 返回顶部 返回列表