吾爱汇编

 找回密码
 立即注册

QQ登录

绑定QQ避免忘记帐号

查看: 10604|回复: 275

[经验资料] 【防逆向】易语言防逆向之对E-Debug的欺骗

  [复制链接]
guo514052476 发表于 2021-9-14 21:25 | 显示全部楼层 |阅读模式

本帖最后由 guo514052476 于 2021-9-14 21:25 编辑

现在逆向的把很多想自己做软件的想法扼杀了  本人前些年也是深受其害 再加上论坛防逆向帖子也不太多 做个小贡献 话说多了 开始正文
E-Debug是逆向的一款常见分析工具
它的作用是帮助逆向者更方便的分析程序,那么咱们可以开辟个曲线救国的思路 从这个软件下手

原理:e-debug只能分析易语言编译的exe,所以咱们把易语言特征抹去特征就行
经过摸索,分析其他的模块总结特征汇编cld finit
图片1.png
就有两种处理方法,第一是直接nop填充掉  第二 内存nop 不修改原来的程序
个人偏向第二种
开始进行具体的操作
首先在开始后进行自进程的内存进行个搜索
然后每个结果都要填充0
具体代码如下:
图片2.png

[ecode=1=4].版本 2

.支持库 webesp



.子程序 抹除特征

.局部变量 局_内存, 类_内存

.局部变量 局_字节集, 整数型, , "0"

.局部变量 局_特征, 字节集

.局部变量 x, 整数型



进程_提升权限到Debug ()  ' 部分电脑遍历内存的时候需要debug权限

局_特征 = 十六进制文本到字节集_ASM (“FCDBE3”)  ' 这个特征是 cld finit 的字节集



局_内存.搜索 (进程_取自进程ID_汇编 (), 局_特征, 局_字节集)  ' 搜索当前进程的内存 并找到特征位置 返回的是数组 但通常是一个

.如果 (取数组成员数 (局_字节集) > 0)

    .计次循环首 (取数组成员数 (局_字节集), x)

        局_内存.写字节集 (进程_取自进程ID_汇编 (), 局_字节集 [x], { 0, 0, 0 })  ' 为了代码和思路的严谨 每处还是要填充下

    .计次循环尾 ()

    信息框 (“成功”, 0, , )

.否则[/ecode]


抹除前:
图片3.png

抹除后:

图片4.png

大功告成

源码分享到下面了

游客,如果您要查看本帖隐藏内容请回复



评分

参与人数 81威望 +1 HB +108 THX +32 收起 理由
入凡尘 + 1
韦韦超 + 1 [吾爱汇编论坛52HB.COM]-软件反汇编逆向分析,软件安全必不可少!
lies + 1
再来壹瓶 + 1 [吾爱汇编论坛52HB.COM]-学破解防破解,知进攻懂防守!
NOP + 2
longge188 + 1 [吾爱汇编论坛52HB.COM]-吃水不忘打井人,给个评分懂感恩!
scarl + 1
太阳神 + 2 + 1 [吾爱汇编论坛52HB.COM]-吃水不忘打井人,给个评分懂感恩!
虚心学习 + 1 [吾爱汇编论坛52HB.COM]-吃水不忘打井人,给个评分懂感恩!
attackmyth + 2 [吾爱汇编论坛52HB.COM]-学破解防破解,知进攻懂防守!
Jawon + 1
ACZR + 2
创客者V2.0 + 1
459121520 + 1
消逝的过去 + 1
极速菜 + 1
WolfKing + 2 [吾爱汇编论坛52HB.COM]-软件反汇编逆向分析,软件安全必不可少!
行行行行行行 + 1
诚速 + 1
风动鸣 + 1 [吾爱汇编论坛52HB.COM]-感谢楼主热心分享,小小评分不成敬意!
sjtkxy + 1
1712585820 + 2 + 1 [吾爱汇编论坛52HB.COM]-软件反汇编逆向分析,软件安全必不可少!
娄胖胖 + 1
yexing + 1
八音 + 1 [吾爱汇编论坛52HB.COM]-软件反汇编逆向分析,软件安全必不可少!
天下一般 + 1
bnjzzheng + 1 [吾爱汇编论坛52HB.COM]-学破解防破解,知进攻懂防守!
temp + 1 + 1
啊啊啊了 + 1
三月十六 + 1
fjgh + 2 + 1 [吾爱汇编论坛52HB.COM]-学破解防破解,知进攻懂防守!
阿枫 + 1
单桥真 + 1
风里去 + 1 [吾爱汇编论坛52HB.COM]-软件反汇编逆向分析,软件安全必不可少!
微熊猫 + 2
zyyujq + 1
侠客行 + 1
MoeRay + 1
无影无踪 + 1 [吾爱汇编论坛52HB.COM]-学破解防破解,知进攻懂防守!
crosssss + 1 [吾爱汇编论坛52HB.COM]-学破解防破解,知进攻懂防守!
Rogue + 1 [吾爱汇编论坛52HB.COM]-学破解防破解,知进攻懂防守!
泉羽 + 1 [吾爱汇编论坛52HB.COM]-吃水不忘打井人,给个评分懂感恩!
不苦小和尚 + 2 + 1 [吾爱汇编论坛52HB.COM]-软件反汇编逆向分析,软件安全必不可少!
ldljlzw + 1
一道彩虹屁 + 1 [吾爱汇编论坛52HB.COM]-感谢楼主热心分享,小小评分不成敬意!
我是好人 + 1 [吾爱汇编论坛52HB.COM]-学破解防破解,知进攻懂防守!
sm5186 + 1 [吾爱汇编论坛52HB.COM]-学破解防破解,知进攻懂防守!
allenzjb + 1
6378895 + 2 + 1
XiaoWeiSec + 1

查看全部评分

吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
aゞ烛火 发表于 2021-9-14 21:37 | 显示全部楼层
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
打不死的小强强 发表于 2021-9-14 22:09 | 显示全部楼层

按钮事件怎么抹掉
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
ChaosC 发表于 2021-9-14 23:29 | 显示全部楼层
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
温九 发表于 2021-9-14 23:42 | 显示全部楼层

看下隐藏内容~~
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
白云点缀的蓝 发表于 2021-9-15 00:05 | 显示全部楼层
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
fyh505099 发表于 2021-9-15 00:09 | 显示全部楼层

厉害 学习了
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
liwenjing 发表于 2021-9-15 00:19 | 显示全部楼层

厉害 学习了
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
E少 发表于 2021-9-15 00:24 | 显示全部楼层

如果我手动还原了再用E_DBUG呢?
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
lies 发表于 2021-9-15 01:24 | 显示全部楼层

谢谢分享,学习了!
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

警告:本站严惩灌水回复,尊重自己从尊重他人开始!

1层
2层
3层
4层
5层
6层
7层
8层
9层
10层

免责声明

吾爱汇编(www.52hb.com)所讨论的技术及相关工具仅限用于研究学习,皆在提高软件产品的安全性,严禁用于不良动机。任何个人、团体、组织不得将其用于非法目的,否则,一切后果自行承担。吾爱汇编不承担任何因为技术滥用所产生的连带责任。吾爱汇编内容源于网络,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑中彻底删除。如有侵权请邮件或微信与我们联系处理。

站长邮箱:SharkHeng@sina.com
站长QQ:1140549900


QQ|RSS|手机版|小黑屋|帮助|吾爱汇编 ( 京公网安备11011502005403号 , 京ICP备20003498号-6 )|网站地图

Powered by Discuz!

吾爱汇编 www.52hb.com

快速回复 返回顶部 返回列表