吾爱汇编

 找回密码
 立即注册

QQ登录

绑定QQ避免忘记帐号

查看: 6474|回复: 129

[原创逆向图文] 简析CheckRemoteDebuggerPresent

  [复制链接]
Very_good 发表于 2021-9-25 19:49 | 显示全部楼层 |阅读模式

首先看一下微软官方的解释

CheckRemoteDebuggerPresent:Determines whether the specified process is being debugged

Syntax
BOOL CheckRemoteDebuggerPresent(
  HANDLE hProcess,
  PBOOL  pbDebuggerPresent
);

Parameters
hProcess
A handle to the process.
pbDebuggerPresent
A pointer to a variable that the function sets to TRUE if the specified process is being debugged, or FALSE otherwise


多的就不贴了 详细可以自己去看

由上边可以知道

CheckRemoteDebuggerPresent有两个参数,一个hProcess(句柄),一个pbDebuggerPresent(是否被调试,调试则返回真,没有调试则返回假)


用易语言写一下


[ecode=1=4].版本 2

.DLL命令 CheckRemoteDebuggerPresent, 逻辑型, "kernel32.dll", "CheckRemoteDebuggerPresent"
    .参数 hProcess, 整数型
    .参数 pbDebuggerPresent, 逻辑型, 传址
[/ecode]

[ecode=1=4].版本 2

.子程序 __启动窗口_创建完毕
.局部变量 A, 逻辑型

CheckRemoteDebuggerPresent (-1, A)
_启动窗口.标题 = 到文本 (A)
[/ecode]

大概就这样,我们直接在易语言里边运行
111.png
然后我们编译好后在桌面打开
222.png
然后我们拖进x32(原版,无任何插件)
333.png

三种情况根据CheckRemoteDebuggerPresent的返回情况看的一清二楚

下面就来介绍一下过检测

拖进x32在CheckRemoteDebuggerPresent下断
444.png

运行
走到77202B4C | 8906                       | mov dword ptr ds:[esi],eax              |

可以发现eax的值变为了1,众所周知,一般真返回1假返回0(也可以说非零即真,只是一般都是返回1)

我们直接eax置0任何运行试试
游客,如果您要查看本帖隐藏内容请回复

评分

参与人数 35威望 +1 HB +52 THX +16 收起 理由
lies + 1
花盗睡鼠 + 2 + 1 [吾爱汇编论坛52HB.COM]-学破解防破解,知进攻懂防守!
虚心学习 + 1 [吾爱汇编论坛52HB.COM]-吃水不忘打井人,给个评分懂感恩!
DDK4282 + 1 [吾爱汇编论坛52HB.COM]-感谢楼主热心分享,小小评分不成敬意!
459121520 + 1
WolfKing + 2 [吾爱汇编论坛52HB.COM]-软件反汇编逆向分析,软件安全必不可少!
后学真 + 1
VipDongle + 1 [吾爱汇编论坛52HB.COM]-软件反汇编逆向分析,软件安全必不可少!
agan8888 + 1
taobao199010 + 1
l278785481 + 1
挖藕 + 1
Wayne + 1 [吾爱汇编论坛52HB.COM]-吃水不忘打井人,给个评分懂感恩!
一蓑烟雨 + 1 + 1 [吾爱汇编论坛52HB.COM]-吃水不忘打井人,给个评分懂感恩!
crosssss + 1 [吾爱汇编论坛52HB.COM]-学破解防破解,知进攻懂防守!
temp + 1 + 1
我是好人 + 1 [吾爱汇编论坛52HB.COM]-学破解防破解,知进攻懂防守!
ldljlzw + 1
playboy + 2
成丰羽 + 1 [吾爱汇编论坛52HB.COM]-感谢楼主热心分享,小小评分不成敬意!
zxjzzh + 1 [吾爱汇编论坛52HB.COM]-学破解防破解,知进攻懂防守!
消逝的过去 + 1 [吾爱汇编论坛52HB.COM]-感谢楼主热心分享,小小评分不成敬意!
allenzjb + 1 + 1
Shin + 1
hetao8003200 + 2 + 1
四曲入云中 + 1
風清. + 1
king51999 + 1 [快捷评语]--积极评分,从我做起。感谢分享!
1413939558 + 1 + 1 [快捷评语]--吃水不忘打井人,给个评分懂感恩!
mengzhisuoliu + 1
保安 + 1 [快捷评语]--你将受到所有人的崇拜!
莣孒嬡沵芣蓜 + 6 + 1 [快捷评语]--你将受到所有人的崇拜!
温九 + 1 + 1 [快捷评语]--你将受到所有人的崇拜!
Shark恒 + 1 + 10 + 1 [快捷评语]--吃水不忘打井人,给个评分懂感恩!
白云点缀的蓝 + 6 + 1 [快捷评语]--积极评分,从我做起。感谢分享!

查看全部评分

本帖被以下淘专辑推荐:

吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
白云点缀的蓝 发表于 2021-9-25 20:19 | 显示全部楼层

现在FZ有一种比较强的反调试检测就是GetStartUpInfo,通过这个函数来判断是否是由od启动的程序
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
温九 发表于 2021-9-25 23:39 | 显示全部楼层

膜拜大佬!大佬牛B!
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
平淡 发表于 2021-9-26 00:03 | 显示全部楼层
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
lies 发表于 2021-9-26 01:04 | 显示全部楼层

谢谢教程,膜拜!
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
snak2020 发表于 2021-9-26 09:11 | 显示全部楼层
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
列明 发表于 2021-9-26 13:30 | 显示全部楼层

講解的很清晰明瞭。
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
ssjjdns 发表于 2021-9-26 15:06 | 显示全部楼层

谢谢分析,谢谢分析!
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
A661910 发表于 2021-9-26 16:11 | 显示全部楼层

GetStartUpInfoGetStartUpInfo
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
manezi 发表于 2021-9-27 06:09 | 显示全部楼层

很好,谢谢楼主
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

警告:本站严惩灌水回复,尊重自己从尊重他人开始!

1层
2层
3层
4层
5层
6层
7层
8层
9层
10层

免责声明

吾爱汇编(www.52hb.com)所讨论的技术及相关工具仅限用于研究学习,皆在提高软件产品的安全性,严禁用于不良动机。任何个人、团体、组织不得将其用于非法目的,否则,一切后果自行承担。吾爱汇编不承担任何因为技术滥用所产生的连带责任。吾爱汇编内容源于网络,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑中彻底删除。如有侵权请邮件或微信与我们联系处理。

站长邮箱:SharkHeng@sina.com
站长QQ:1140549900


QQ|RSS|手机版|小黑屋|帮助|吾爱汇编 ( 京公网安备11011502005403号 , 京ICP备20003498号-6 )|网站地图

Powered by Discuz!

吾爱汇编 www.52hb.com

快速回复 返回顶部 返回列表