吾爱汇编论坛

 找回密码
 立即注册

QQ登录

绑定QQ避免忘记帐号

查看: 667|回复: 72

[易语言] 开源穿越某线的删除指定文件达到清理残留效果

  [复制链接]

  在线 

升级   90.62%

Shark_鹏 发表于 2021-11-10 20:41 | 显示全部楼层 |阅读模式


[ecode=1].版本 2
.支持库 shell

.子程序 __启动窗口_创建完毕

编辑框_游戏路径.内容 = 到大写 (取文本注册项 (4, “Software\Tencent\CrossFire\InstallPath”, ))


.子程序 _按钮1_被单击
.局部变量 目录, 文本型

.如果真 (编辑框_游戏路径.内容 = “”)
    编辑框_游戏路径.内容 = 浏览文件夹 (“获取游戏目录失败,请手动选择游戏目录!” + #换行符 + “例如:E:\腾讯游戏\穿越火线”, )
    .如果真 (目录_是否存在 (编辑框_游戏路径.内容 + “\X64”))
        信息框 (“游戏路径填写错误,请从新选择目录!”, 0, , )
        返回 ()
    .如果真结束

.如果真结束

目录 = 编辑框_游戏路径.内容 + “\X64\d3dref9.dll”


.如果 (文件_是否存在 (编辑框_游戏路径.内容 + “\X64\d3dref9.dll”) = 真)

    文件_强制删除文件 (目录)  ' 防止之前残留,必须删除一次


    信息框 (“残留清理完毕!”, 0, , )
.否则
    信息框 (“检测到无残留,无需清理!”, 0, , )
.如果结束


[/ecode]

评分

参与人数 10HB +16 THX +6 收起 理由
agan8888 + 1
mxjxz + 1 [吾爱汇编论坛52HB.COM]-感谢楼主热心分享,小小评分不成敬意!
zxjzzh + 1 [吾爱汇编论坛52HB.COM]-学破解防破解,知进攻懂防守!
pmm018 + 1
king51999 + 1 [吾爱汇编论坛52HB.COM]-吃水不忘打井人,给个评分懂感恩!
jhf123 + 1 [快捷评语]--吃水不忘打井人,给个评分懂感恩!
sibaichi + 1
白云点缀的蓝 + 6 + 1 [快捷评语]--评分=感恩!简单却充满爱!感谢您的作品!
1300841139 + 2
ST手怎么白了 + 5 + 1 [快捷评语]--吃水不忘打井人,给个评分懂感恩!

查看全部评分

吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

ST手怎么白了 发表于 2021-11-10 20:45 | 显示全部楼层


这个功能。。。似曾相识

点评

就是简单的获取路径或者浏览文件夹 然后删除指定dll  详情 回复 发表于 2021-11-10 20:56
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

升级   73.33%

1300841139 发表于 2021-11-10 20:53 | 显示全部楼层


谢谢分享大佬
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  在线 

升级   90.62%

 楼主| Shark_鹏 发表于 2021-11-10 20:56 | 显示全部楼层


ST手怎么白了 发表于 2021-11-10 20:45
这个功能。。。似曾相识

就是简单的获取路径或者浏览文件夹  然后删除指定dll
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

升级   60%

sibaichi 发表于 2021-11-11 09:04 | 显示全部楼层


感谢分享。学习一下
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

升级   65%

yuan2020 发表于 2021-11-23 17:02 | 显示全部楼层
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

升级   60%

sibaichi 发表于 2021-11-24 02:15 | 显示全部楼层


文件_强制删除文件这个咋搞。。。
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

升级   10%

a821578077 发表于 2022-1-22 09:32 | 显示全部楼层


感谢楼主
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

升级   5%

负责迎蜗牛 发表于 2022-1-22 19:16 | 显示全部楼层


谢谢分享
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

升级   5%

诚心给板凳 发表于 2022-1-22 20:00 | 显示全部楼层


感谢楼主
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则 警告:本站严惩灌水回复,尊重自己从尊重他人开始!

1层
2层
3层
4层
5层
6层
7层
8层
9层
10层

免责声明

吾爱汇编论坛(www.52hb.com)所发布的破解补丁、注册机、逆向教程、逆向文章等,包含但不限于上述内容,仅限用于学习和研究目的,不得用于非法途径或商业行为。否则,一切后果请用户自行承担。本站内容源于网络,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑中彻底删除。如果您喜欢某程序,请购买正版,支持正版,获得正版优质服务。如有侵权请邮件或微信与我们联系处理。

站长邮箱:SharkHeng@iCloud.com
站长微信:SharkHeng


QQ|RSS|手机版|小黑屋|帮助|吾爱汇编论坛 ( 京公网安备11011502005403号 , 京ICP备20003498号 )

GMT+8, 2022-5-21 08:32 , Processed in 0.447583 second(s), 73 queries .

Powered by Discuz!

吾爱汇编论坛 www.52hb.com

快速回复 返回顶部 返回列表