吾爱汇编论坛

 找回密码
 立即注册

QQ登录

绑定QQ避免忘记帐号

查看: 2577|回复: 82

[易语言] 开源CF注册表劫持注入

  [复制链接]

  离线 

Shark_鹏 发表于 2021-12-6 09:12 | 显示全部楼层 |阅读模式

[ecode=1].版本 2
.支持库 EThread
.支持库 shell
.支持库 spec

.程序集 窗口
.程序集变量 DLL数据, 字节集
.程序集变量 获取路径, 文本型

.子程序 __启动窗口_创建完毕

启动线程 (&设置注入, , )

.子程序 设置注入

写到文件 (取特定目录 (10) + “dinput8d.dll”, #DLL)
ACP_注入 (取特定目录 (10) + “dinput8d.dll”)
延时 (5000)
结束 ()

.子程序 ACP_注入, 逻辑型
.参数 值, 文本型
.局部变量 局部_注册表项句柄, 整数型
.局部变量 局部_新子项句柄, 整数型
.局部变量 局部_新值长度, 整数型
.局部变量 返回值, 整数型

.判断开始 (打开注册表项_ (-2147483647, “SOFTWARE”, 局部_注册表项句柄) = 0)
    .判断开始 (设置指定项或子项默认值_ (局部_注册表项句柄, “Classes\CLSID\{25E609E4-B259-11CF-BFC7-444553540000}\InProcServer32\”, 1, 值, 局部_新值长度) = 0)
        调用子程序 (GetProcAddress (GetModuleHandleA (“advapi32.dll”), “RegCloseKey”), , 返回值, 局部_注册表项句柄)
        .如果真 (返回值 ≠ 0)
            返回 (假)
        .如果真结束

    .默认
        返回 (假)
    .判断结束

.默认
    返回 (假)
.判断结束
返回 (真)

[/ecode]


[ecode=1].版本 2

.DLL命令 CreateFileMappingA, 整数型
    .参数 hFile, 整数型
    .参数 lpFileMappingAttributes, 整数型
    .参数 flProtect, 整数型
    .参数 dwMaximumSizeHigh, 整数型
    .参数 dwMaximumSizeLow, 整数型
    .参数 lpName, 文本型

.DLL命令 MapViewOfFile, 整数型
    .参数 hFileMappingObject, 整数型
    .参数 dwDesiredAccess, 整数型
    .参数 dwFileOffsetHigh, 整数型
    .参数 dwFileOffsetLow, 整数型
    .参数 dwNumberOfBytesToMap, 整数型

.DLL命令 UnmapViewOfFile, 逻辑型
    .参数 lpBaseAddress, 整数型

.DLL命令 CloseHandle, 逻辑型
    .参数 hObject, 整数型

.DLL命令 设置指定项或子项默认值_, 整数型, "advapi32", "RegSetValueA"
    .参数 项句柄, 整数型
    .参数 子项名字, 文本型, 传址
    .参数 类型, 整数型
    .参数 新值, 文本型, 传址
    .参数 新值长度, 整数型

.DLL命令 GetModuleHandleA, 整数型, "kernel32.dll", "GetModuleHandleA"
    .参数 模块名, 文本型

.DLL命令 打开注册表项_, 整数型, "advapi32", "RegOpenKeyA"
    .参数 标准项名或句柄, 整数型
    .参数 项名, 文本型
    .参数 打开注册表项句柄, 整数型, 传址

.DLL命令 GetProcAddress, 整数型, "kernel32.dll", "GetProcAddress"
    .参数 模块句柄, 整数型
    .参数 进程名称, 文本型
[/ecode]

评分

参与人数 32HB +38 THX +15 收起 理由
后学真 + 1
飞刀梦想 + 1
wjks86 + 1
zxjzzh + 2 [吾爱汇编论坛52HB.COM]-学破解防破解,知进攻懂防守!
jia54109147 + 1 [吾爱汇编论坛52HB.COM]-软件反汇编逆向分析,软件安全必不可少!
agan8888 + 1
武清一点点 + 1
小声点我布隆 + 1 [吾爱汇编论坛52HB.COM]-吃水不忘打井人,给个评分懂感恩!
为了爱偷铁卖 + 1
pmm018 + 1
boot + 2
a1fnv3llnq + 1
wbxs2077 + 2 + 1 [吾爱汇编论坛52HB.COM]-吃水不忘打井人,给个评分懂感恩!
wenrou999 + 1 [吾爱汇编论坛52HB.COM]-吃水不忘打井人,给个评分懂感恩!
xx001 + 1 [吾爱汇编论坛52HB.COM]-吃水不忘打井人,给个评分懂感恩!
8wy721719 + 1 [吾爱汇编论坛52HB.COM]-感谢楼主热心分享,小小评分不成敬意!
2511460545 + 1 [快捷评语]--2021年,我们爱0爱1
king51999 + 1 [快捷评语]--评分=感恩!简单却充满爱!感谢您的作品!
foreversos + 1
w272743042 + 1 + 1 [快捷评语]--吃水不忘打井人,给个评分懂感恩!
AK520 + 3 [通知]学破解论坛即将在近期更名为吾爱汇编论坛WWW.52HB.COM
Camille + 1 + 1 --------
kuai7758521 + 1 + 1 [通知]学破解论坛即将在近期更名为吾爱汇编论坛WWW.52HB.COM
531814517 + 1 [通知]学破解论坛即将在近期更名为吾爱汇编论坛WWW.52HB.COM
Tian_52HB + 1
白云点缀的蓝 + 6 + 1 [快捷评语]--2021年,我们爱0爱1
muker + 1 [快捷评语]--你将受到所有人的崇拜!
cunzhang2016 + 1 [通知]学破解论坛即将在近期更名为吾爱汇编论坛WWW.52HB.COM
xiatianwl + 1 论坛的秩序需要大家共同监督与维护,感谢!
小G一小只 + 1 [通知]学破解论坛即将在近期更名为吾爱汇编论坛WWW.52HB.COM
zer0 + 1 + 1
ST手怎么白了 + 5 + 1 [通知]学破解论坛即将在近期更名为吾爱汇编论坛WWW.52HB.COM

查看全部评分

吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

ST手怎么白了 发表于 2021-12-6 09:22 | 显示全部楼层
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

蚁上火 发表于 2021-12-6 09:44 | 显示全部楼层

为什么不直接放E源码呢 哈哈
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

xiatianwl 发表于 2021-12-6 15:31 | 显示全部楼层
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

sibaichi 发表于 2021-12-6 17:11 | 显示全部楼层

瞧瞧看。感谢分享
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

x5龙龙 发表于 2021-12-6 18:19 | 显示全部楼层

为什么不直接放E源码呢

点评

Shark_鹏”点评说:
这个跟E源码有啥区别么。。。。  详情 回复 发表于 2021-12-6 19:25
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

 楼主| Shark_鹏 发表于 2021-12-6 19:25 | 显示全部楼层

x5龙龙 发表于 2021-12-6 18:19
为什么不直接放E源码呢

这个跟E源码有啥区别么。。。。
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

白云点缀的蓝 发表于 2021-12-6 23:29 | 显示全部楼层

thank you~~~
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

a2605720503 发表于 2021-12-10 02:22 | 显示全部楼层

学习学习学习xx
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM

  离线 

Anonymous 发表于 2021-12-11 10:11 | 显示全部楼层

感谢学习请问这个需要卸载吗
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

警告:本站严惩灌水回复,尊重自己从尊重他人开始!

1层
2层
3层
4层
5层
6层
7层
8层
9层
10层

免责声明

吾爱汇编论坛(www.52hb.com)所讨论的技术及相关工具仅限用于研究学习,皆在提高软件产品的安全性,严禁用于不良动机。任何个人、团体、组织不得将其用于非法目的,否则,一切后果自行承担。吾爱汇编论坛不承担任何因为技术滥用所产生的连带责任。吾爱汇编论坛内容源于网络,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑中彻底删除。如有侵权请邮件或微信与我们联系处理。

站长邮箱:SharkHeng@sina.com
站长微信:SharkHeng


QQ|RSS|手机版|小黑屋|帮助|吾爱汇编论坛 ( 京公网安备11011502005403号 , 京ICP备20003498号-6 )|网站地图

0.094070 , 64

Powered by Discuz!

吾爱汇编论坛 www.52hb.com

快速回复 返回顶部 返回列表