吾爱汇编

 找回密码
 立即注册

QQ登录

绑定QQ避免忘记帐号

查看: 1071|回复: 2

易语言一段置入代码怎么转换成远程汇编的啊

[复制链接]
loos2233 发表于 2023-3-9 01:35 | 显示全部楼层 |阅读模式

本站严厉禁止求脱求破行为(包含无自我分析直接求思路),如发现此类求助主题请点击“举报”,让我们共同维护优质的学习环境!


30HB
.版本 2

.子程序 取目标指针, 整数型
.参数 目标指针, 整数型
' 置入代码 ({ 139, 125, 8, 139, 7, 137, 249, 139, 128, 92, 2, 0, 0, 255, 208, 201, 194, 4, 0 })
返回 (0)


.子程序 取D3D指针, 整数型
.参数 变量, D3DXVECTOR3, 参考

' 置入代码 ({ 96, 139, 69, 8, 139, 0, 139, 229, 93, 194, 4, 0, 97 })
返回 (0)

转换成这种格式的
置汇编代码 ({  })
清空汇编代码 ()
Pushad ()
' XXXXXXX
' XXXXXXX
' XXXXXXX
Popad ()
ret ()
开始Virus (进程ID)
汇编远程执行 (取汇编代码 ())
结束Virus ()



吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
梨花丶 发表于 2023-3-9 12:09 | 显示全部楼层

本帖最后由 梨花丶 于 2023-3-9 12:12 编辑

魔鬼作坊命令  转换_字节集转汇编( 了解一下)
置入代码 ({ 139, 125, 8, 139, 7, 137, 249, 139, 128, 92, 2, 0, 0, 255, 208, 201, 194, 4, 0 })
转换为

' mov edi, dword ptr [ebp+0x08]
' mov eax, dword ptr [edi]
' mov ecx, edi
' mov eax, dword ptr [eax+0x0000025c]
' call eax
' leave
' retn 0x0004
QQ图片20230309121144.png
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
温九 发表于 2023-3-10 15:31 | 显示全部楼层

先把字节集转换成汇编 然后调用汇编类插入代码就可以了
吾爱汇编论坛-学破解,防破解!知进攻,懂防守!逆向分析,软件安全!52HB.COM
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

警告:本站严惩灌水回复,尊重自己从尊重他人开始!

1层
2层
3层

免责声明

吾爱汇编(www.52hb.com)所讨论的技术及相关工具仅限用于研究学习,皆在提高软件产品的安全性,严禁用于不良动机。任何个人、团体、组织不得将其用于非法目的,否则,一切后果自行承担。吾爱汇编不承担任何因为技术滥用所产生的连带责任。吾爱汇编内容源于网络,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑中彻底删除。如有侵权请邮件或微信与我们联系处理。

站长邮箱:SharkHeng@sina.com
站长QQ:1140549900


QQ|RSS|手机版|小黑屋|帮助|吾爱汇编 ( 京公网安备11011502005403号 , 京ICP备20003498号-6 )|网站地图

Powered by Discuz!

吾爱汇编 www.52hb.com

快速回复 返回顶部 返回列表